Konfigurasi RIP Cisco Packet Tracert

Konfigurasi RIP Cisco Packet Tracert - Routing Information Protocol atau biasa kita sebut dengan RIP, adalah sebuah protokol routing yang sangat sederhana dan routing protokol jenis ini masuk kedalam kategori Interior Gateway Protocol.


Protokol routing jenis ini, menggunakan algoritma yang hanya melihat jarak dari asal ke jaringan tujuan nya. Router router yang menjalankan RIP, akan saling bertukar informasi yang dia punya sehingga masing masing router tahu jarak terkecil yang akan dia pakai untuk menyampaikan data.

Lalu, di Cisco sendiri mempunyai 2 Versi RIP, yaitu


  1. RIPv1
  2. RIPv2
Apa perbedaan dari masing masing versi tersebut dan apa kelebihannya dari masing masing versinya ? 

  • Routing Information Protocol versi 1 (RIPv1)
Adalah jenis protokol routing yang akan mengirimkan Routing table miliknya secara broadcast, atau dia akan mengirimkan routing table yang dia punya ke semua router yang terhubung dalam satu jaringan. Kelemahan dari RIPv1 ini adalah tidak mendukung VLSM (Virtual Length Subnet Mask).

  • Routing Information Protocol versi 2 (RIPv2)
Ialah jenis protokol routing yang mengirimkan table routing nya secara multicast dan memiliki fitur authentication. Berbeda dengan RIPv1 sebelumnya, RIPv2 ini sudah mendukung VLSM, sehingga akan lebih irit atau hemat dalam pemakaian IP Address.


Tutorial


Dalam tutorial kali ini saya akan mempraktikan konfigurasi RIP, berikut adalah topology beserta keterangannya :

Keterangan :

IP Jaringan :
  1. 192.168.10.0/24
  2. 192.168.20.0/24
  3. 192.168.30.0/24
IP Router :
  • Router1 > Router2 : 10.10.10.0/30
  • Router2 > Router3 : 10.10.10.4/30
  • Router3 > Router1 : 10.10.10.8/30
Gateway : Masing masing first host.

  • Petama tama saya akan konfigurasikan IP Address pada Router1

Router>enable
Router#configure terminal
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#exit
Router(config)#interface serial 0/1/1
Router(config-if)#no shutdown
Router(config-if)#ip address 10.10.10.1 255.255.255.252
Router(config-if)#exit
Router(config)#interface serial 0/1/0
Router(config-if)#no shutdown
Router(config-if)#ip address 10.10.10.9 255.255.255.252
Router(config-if)#exit 

  • Lalu saya akan konfigurasikan IP juga pada Router2

Router>enable
Router#configure terminal
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.20.1 255.255.255.0
Router(config-if)#exit
Router(config)#interface serial 0/1/0
Router(config-if)#no shutdown
Router(config-if)#ip address 10.10.10.2 255.255.255.252
Router(config-if)#exit
Router(config)#interface serial 0/1/1
Router(config-if)#no shutdown
Router(config-if)#ip address 10.10.10.5 255.255.255.252
Router(config-if)#exit

  •  Selanjutnya, konfigurasikan juga IP address untuk Router3

Router#configure terminal
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.30.1 255.255.255.0
Router(config-if)#exit
Router(config)#interface serial 0/1/0
Router(config-if)#no shutdown
Router(config-if)#ip address 10.10.10.6 255.255.255.252
Router(config-if)#exit
Router(config)#interface serial 0/1/1
Router(config-if)#no shutdown
Router(config-if)#ip address 10.10.10.10 255.255.255.252
Router(config-if)#exit
IP addres udah terkonfigurasi di masing masing router, sekarang saat nya di langkah paling dicari :D, yaitu konfigurasi RIP nya.

HARAP DIBACA:
Kali ini saya akan mengkonfigurasikan RIPv2, tidak ada perbedaan dalam konfigurasinya, hanya saja jika RIPv1, tidak perlu memasukan comment version 2. berikut adalah tutorialnya .


  • Router1

Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.10.0 0.0.0.255
Router(config-router)#network 192.168.10.0
Router(config-router)#network 10.10.10.0
Router(config-router)#network 10.10.10.8

  •  Router2

Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.20.0
Router(config-router)#network 10.10.10.0
Router(config-router)#network 10.10.10.4

  • Router3

Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.30.0
Router(config-router)#network 10.10.10.4
Router(config-router)#network 10.10.10.8 
Konfigurasi RIP sudah selesai, silahkan dicoba.
Eiiiiitttsss.... jangan lupa, sebelumnya kita belum memberikan IP Address pada PC, silahkan masukan IP Address pada PC sesuai dengan network yang ditentukan

Click to comment